package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[$]([{])?([0-9]+)?(?(2)|(?:TM_FILENAME))(?(1)(?(2)[:].+|[\/].+[\/].*[\/])})`)
var str = `If-Then-Else Conditionals in Regular Expressions
http://www.regular-expressions.info/conditional.html
$TM_FILENAME //GOOD
$1 //GOOD
${1:} //BAD: empty default value
${1:a} //GOOD
${TM_FILENAME/[\.]/_/} //GOOD
${TM_FILENAME:a|b} //BAD: cannot set default value to static var
${TM_FILENAME/} //BAD: illegal: only one \`/\` (need3)
${TM_FILENAME/a/} //BAD: illegal: only two \`/\` (need3)
${TM_FILENAME/a//} //GOOD: not empty between first two \`/\`
${TM_FILENAME//abc/} //BAD: this should not match: empty between first two \`/\`
${TM_FILENAME/a//a} //BAD: not \`}\` after last \`/\`
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}