import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[$]([\\{])?([0-9]+)?(?(2)|(?:TM_FILENAME))(?(1)(?(2)[:].+|[\\/].+[\\/].*[\\/])\\})";
final String string = "If-Then-Else Conditionals in Regular Expressions\n"
+ "http://www.regular-expressions.info/conditional.html\n\n"
+ "$TM_FILENAME //GOOD\n"
+ "$1 //GOOD\n"
+ "${1:} //BAD: empty default value\n"
+ "${1:a} //GOOD\n"
+ "${TM_FILENAME/[\\.]/_/} //GOOD\n"
+ "${TM_FILENAME:a|b} //BAD: cannot set default value to static var\n"
+ "${TM_FILENAME/} //BAD: illegal: only one `/` (need3)\n"
+ "${TM_FILENAME/a/} //BAD: illegal: only two `/` (need3)\n"
+ "${TM_FILENAME/a//} //GOOD: not empty between first two `/` \n"
+ "${TM_FILENAME//abc/} //BAD: this should not match: empty between first two `/` \n"
+ "${TM_FILENAME/a//a} //BAD: not `}` after last `/` \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}