const regex = /[$]([{])?([0-9]+)?(?(2)|(?:TM_FILENAME))(?(1)(?(2)[:].+|[\/].+[\/].*[\/])})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[$]([{])?([0-9]+)?(?(2)|(?:TM_FILENAME))(?(1)(?(2)[:].+|[\\\/].+[\\\/].*[\\\/])})', 'gm')
const str = `If-Then-Else Conditionals in Regular Expressions
http://www.regular-expressions.info/conditional.html
\$TM_FILENAME //GOOD
\$1 //GOOD
\${1:} //BAD: empty default value
\${1:a} //GOOD
\${TM_FILENAME/[\\.]/_/} //GOOD
\${TM_FILENAME:a|b} //BAD: cannot set default value to static var
\${TM_FILENAME/} //BAD: illegal: only one \`/\` (need3)
\${TM_FILENAME/a/} //BAD: illegal: only two \`/\` (need3)
\${TM_FILENAME/a//} //GOOD: not empty between first two \`/\`
\${TM_FILENAME//abc/} //BAD: this should not match: empty between first two \`/\`
\${TM_FILENAME/a//a} //BAD: not \`}\` after last \`/\`
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}