#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xu)(?:" & @CRLF & _
" (https?) :/{2}" & @CRLF & _
")?" & @CRLF & _
"(" & @CRLF & _
" \w+" & @CRLF & _
" (?:\.\w+)+" & @CRLF & _
")"
Local $sString = "example.com" & @CRLF & _
"www.example.com" & @CRLF & _
"http://example.com" & @CRLF & _
"https://example.com" & @CRLF & _
"http://www.one.two.three.example.com" & @CRLF & _
"example.com/stuff" & @CRLF & _
"example.com/?key1=value1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")