$re = '~(?:
(https?) :/{2}
)?
(
\w+
(?:\.\w+)+
)~xu';
$str = 'example.com
www.example.com
http://example.com
https://example.com
http://www.one.two.three.example.com
example.com/stuff
example.com/?key1=value1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);