package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x)(?:
(https?) :/{2}
)?
(
\w+
(?:\.\w+)+
)`)
var str = `example.com
www.example.com
http://example.com
https://example.com
http://www.one.two.three.example.com
example.com/stuff
example.com/?key1=value1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}