import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\n"
+ " (https?) :/{2}\n"
+ ")?\n"
+ "(\n"
+ " \\w+\n"
+ " (?:\\.\\w+)+\n"
+ ")";
final String string = "example.com\n"
+ "www.example.com\n"
+ "http://example.com\n"
+ "https://example.com\n"
+ "http://www.one.two.three.example.com\n"
+ "example.com/stuff\n"
+ "example.com/?key1=value1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}