const regex = new RegExp('(?:
(https?) :/{2}
)?
(
\\w+
(?:\\.\\w+)+
)', 'gu')
const str = `example.com
www.example.com
http://example.com
https://example.com
http://www.one.two.three.example.com
example.com/stuff
example.com/?key1=value1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}