#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[0-9a-zA-Z]{32,39}+(?:[0-9a-zA-Z]{2,6})?\b"
Local $sString = "12345678901234567890123456789012" & @CRLF & _
"123456789012345678901234567890123" & @CRLF & _
"1234567890123456789012345678901234" & @CRLF & _
"12345678901234567890123456789012356" & @CRLF & _
"123456789012345678901234567890123567" & @CRLF & _
"1234567890123456789012345678901235678" & @CRLF & _
"12345678901234567890123456789012356789" & @CRLF & _
"123456789012345678901234567890123567890" & @CRLF & _
"1234567890123456789012345678901235678901" & @CRLF & _
"12345678901234567890123456789012356789012" & @CRLF & _
"123456789012345678901234567890123567890123" & @CRLF & _
"1234567890123456789012345678901235678901234" & @CRLF & _
"12345678901234567890123456789012356789012345" & @CRLF & _
"123456789012345678901234567890123456789012345" & @CRLF & _
"1234567890123456789012345678901234567890123456" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")