import re
regex = re.compile(r"\b[0-9a-zA-Z]{32,39}+(?:[0-9a-zA-Z]{2,6})?\b", flags=re.MULTILINE)
test_str = ("12345678901234567890123456789012\n"
"123456789012345678901234567890123\n"
"1234567890123456789012345678901234\n"
"12345678901234567890123456789012356\n"
"123456789012345678901234567890123567\n"
"1234567890123456789012345678901235678\n"
"12345678901234567890123456789012356789\n"
"123456789012345678901234567890123567890\n"
"1234567890123456789012345678901235678901\n"
"12345678901234567890123456789012356789012\n"
"123456789012345678901234567890123567890123\n"
"1234567890123456789012345678901235678901234\n"
"12345678901234567890123456789012356789012345\n"
"123456789012345678901234567890123456789012345\n"
"1234567890123456789012345678901234567890123456\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")