$re = '/\b[0-9a-zA-Z]{32,39}+(?:[0-9a-zA-Z]{2,6})?\b/m';
$str = '12345678901234567890123456789012
123456789012345678901234567890123
1234567890123456789012345678901234
12345678901234567890123456789012356
123456789012345678901234567890123567
1234567890123456789012345678901235678
12345678901234567890123456789012356789
123456789012345678901234567890123567890
1234567890123456789012345678901235678901
12345678901234567890123456789012356789012
123456789012345678901234567890123567890123
1234567890123456789012345678901235678901234
12345678901234567890123456789012356789012345
123456789012345678901234567890123456789012345
1234567890123456789012345678901234567890123456
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);