using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[0-9a-zA-Z]{32,39}+(?:[0-9a-zA-Z]{2,6})?\b";
string input = @"12345678901234567890123456789012
123456789012345678901234567890123
1234567890123456789012345678901234
12345678901234567890123456789012356
123456789012345678901234567890123567
1234567890123456789012345678901235678
12345678901234567890123456789012356789
123456789012345678901234567890123567890
1234567890123456789012345678901235678901
12345678901234567890123456789012356789012
123456789012345678901234567890123567890123
1234567890123456789012345678901235678901234
12345678901234567890123456789012356789012345
123456789012345678901234567890123456789012345
1234567890123456789012345678901234567890123456
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}