import Foundation
let pattern = #"\b[0-9a-zA-Z]{32,39}+(?:[0-9a-zA-Z]{2,6})?\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
12345678901234567890123456789012
123456789012345678901234567890123
1234567890123456789012345678901234
12345678901234567890123456789012356
123456789012345678901234567890123567
1234567890123456789012345678901235678
12345678901234567890123456789012356789
123456789012345678901234567890123567890
1234567890123456789012345678901235678901
12345678901234567890123456789012356789012
123456789012345678901234567890123567890123
1234567890123456789012345678901235678901234
12345678901234567890123456789012356789012345
123456789012345678901234567890123456789012345
1234567890123456789012345678901234567890123456
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)