// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[0-9a-zA-Z]{32,39}+(?:[0-9a-zA-Z]{2,6})?\b").unwrap();
let string = "12345678901234567890123456789012
123456789012345678901234567890123
1234567890123456789012345678901234
12345678901234567890123456789012356
123456789012345678901234567890123567
1234567890123456789012345678901235678
12345678901234567890123456789012356789
123456789012345678901234567890123567890
1234567890123456789012345678901235678901
12345678901234567890123456789012356789012
123456789012345678901234567890123567890123
1234567890123456789012345678901235678901234
12345678901234567890123456789012356789012345
123456789012345678901234567890123456789012345
1234567890123456789012345678901234567890123456
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}