# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})(\s*,\s*(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}))*//;t' <<< "10.1.1.1,123.123.123.123,192.192.192.192"