re = /(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})(\s*,\s*(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}))*/
str = '10.1.1.1,123.123.123.123,192.192.192.192'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result