import Foundation
let pattern = #"(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})(\s*,\s*(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}))*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"10.1.1.1,123.123.123.123,192.192.192.192"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}