use strict;
my $str = 'pass:
aaaaaaaa
bbbbbbbbb
ccccccccdefg
11111111
spaces
fail:
aaaaaaa
aaaaaaab
abababababababab
1111111';
my $regex = qr/^(.)\1{7}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}