re = /^(.)\1{7}/m
str = 'pass:
aaaaaaaa
bbbbbbbbb
ccccccccdefg
11111111
spaces
fail:
aaaaaaa
aaaaaaab
abababababababab
1111111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end