$re = '/^(.)\1{7}/m';
$str = 'pass:
aaaaaaaa
bbbbbbbbb
ccccccccdefg
11111111
spaces
fail:
aaaaaaa
aaaaaaab
abababababababab
1111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);