#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^abc4(?:.*(?:[^p].{2}|p[^r].{1}|pr[^e])|.{0,2})$"
Local $sString = "abc4back" & @CRLF & _
"abc4backpre" & @CRLF & _
"abc4front" & @CRLF & _
"abc4frontpre" & @CRLF & _
"abc3side" & @CRLF & _
"abc3sidepre" & @CRLF & _
"xyz4over" & @CRLF & _
"xyz4overpre" & @CRLF & _
"abc4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")