import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^abc4(?:.*(?:[^p].{2}|p[^r].{1}|pr[^e])|.{0,2})$";
final String string = "abc4back\n"
+ "abc4backpre\n"
+ "abc4front\n"
+ "abc4frontpre\n"
+ "abc3side\n"
+ "abc3sidepre\n"
+ "xyz4over\n"
+ "xyz4overpre\n"
+ "abc4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}