$re = '`^abc4(?:.*(?:[^p].{2}|p[^r].{1}|pr[^e])|.{0,2})$`m';
$str = 'abc4back
abc4backpre
abc4front
abc4frontpre
abc3side
abc3sidepre
xyz4over
xyz4overpre
abc4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);