using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((\+92)?(0092)?(92)?(0)?)(3)([0-9]{9})$";
string input = @"// Validate it
+923001234567
00923001234567
923001234567
03001234567
3001234567
// Don't Validate
+3001234567
+933001234567
+9230012345672
+923001234567200
030012345672
30012345673";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}