# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((\+92)?(0092)?(92)?(0)?)(3)([0-9]{9})$"
test_str = ("// Validate it\n\n"
"+923001234567\n"
"00923001234567\n"
"923001234567\n"
"03001234567\n"
"3001234567\n\n\n"
"// Don't Validate \n"
"+3001234567\n"
"+933001234567\n"
"+9230012345672\n"
"+923001234567200\n"
"030012345672\n"
"30012345673")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.