$re = '/^((\+92)?(0092)?(92)?(0)?)(3)([0-9]{9})$/m';
$str = '// Validate it
+923001234567
00923001234567
923001234567
03001234567
3001234567
// Don\'t Validate
+3001234567
+933001234567
+9230012345672
+923001234567200
030012345672
30012345673';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);