const regex = /^((\+92)?(0092)?(92)?(0)?)(3)([0-9]{9})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((\\+92)?(0092)?(92)?(0)?)(3)([0-9]{9})$', 'gm')
const str = `// Validate it
+923001234567
00923001234567
923001234567
03001234567
3001234567
// Don't Validate
+3001234567
+933001234567
+9230012345672
+923001234567200
030012345672
30012345673`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}