re = /^((\+92)?(0092)?(92)?(0)?)(3)([0-9]{9})$/m
str = '// Validate it
+923001234567
00923001234567
923001234567
03001234567
3001234567
// Don\'t Validate
+3001234567
+933001234567
+9230012345672
+923001234567200
030012345672
30012345673'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end