#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(\d)(?:-?\1)*$)\d{2}-?\d{7}$"
Local $sString = "00-0000000" & @CRLF & _
"000000000" & @CRLF & _
"11-1111111" & @CRLF & _
"111111111" & @CRLF & _
"22-2222222" & @CRLF & _
"222222222" & @CRLF & _
"99-9999999" & @CRLF & _
"999999999" & @CRLF & _
"123456789" & @CRLF & _
"12-3456789" & @CRLF & _
"22-2222221"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")