$re = '/^(?!(\d)(?:-?\1)*$)\d{2}-?\d{7}$/m';
$str = '00-0000000
000000000
11-1111111
111111111
22-2222222
222222222
99-9999999
999999999
123456789
12-3456789
22-2222221';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);