const regex = /^(?!(\d)(?:-?\1)*$)\d{2}-?\d{7}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(\\d)(?:-?\\1)*$)\\d{2}-?\\d{7}$', 'gm')
const str = `00-0000000
000000000
11-1111111
111111111
22-2222222
222222222
99-9999999
999999999
123456789
12-3456789
22-2222221`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}