import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(\\d)(?:-?\\1)*$)\\d{2}-?\\d{7}$";
final String string = "00-0000000\n"
+ "000000000\n"
+ "11-1111111\n"
+ "111111111\n"
+ "22-2222222\n"
+ "222222222\n"
+ "99-9999999\n"
+ "999999999\n"
+ "123456789\n"
+ "12-3456789\n"
+ "22-2222221";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}