use strict;
my $str = '00-0000000
000000000
11-1111111
111111111
22-2222222
222222222
99-9999999
999999999
123456789
12-3456789
22-2222221';
my $regex = qr/^(?!(\d)(?:-?\1)*$)\d{2}-?\d{7}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}