using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(\d)(?:-?\1)*$)\d{2}-?\d{7}$";
string input = @"00-0000000
000000000
11-1111111
111111111
22-2222222
222222222
99-9999999
999999999
123456789
12-3456789
22-2222221";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}