package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+[ ]?(?:lac|crs?|k)`)
var str = `it should not match this65 lac and this 55 lacand this87lacdsdsa
but it should match 76 lac. and 87 cr. including . at the end as well.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}