// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+[ ]?(?:lac|crs?|k)").unwrap();
let string = "it should not match this65 lac and this 55 lacand this87lacdsdsa
but it should match 76 lac. and 87 cr. including . at the end as well.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}