re = /\d+[ ]?(?:lac|crs?|k)/m
str = 'it should not match this65 lac and this 55 lacand this87lacdsdsa
but it should match 76 lac. and 87 cr. including . at the end as well.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end