const regex = /\d+[ ]?(?:lac|crs?|k)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+[ ]?(?:lac|crs?|k)', 'gm')
const str = `it should not match this65 lac and this 55 lacand this87lacdsdsa
but it should match 76 lac. and 87 cr. including . at the end as well.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}