$re = '/\d+[ ]?(?:lac|crs?|k)/m';
$str = 'it should not match this65 lac and this 55 lacand this87lacdsdsa
but it should match 76 lac. and 87 cr. including . at the end as well.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);