use strict;
my $str = 'it should not match this65 lac and this 55 lacand this87lacdsdsa
but it should match 76 lac. and 87 cr. including . at the end as well.';
my $regex = qr/\d+[ ]?(?:lac|crs?|k)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}