# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?-s)^([^:]+:).*(\R\1.*)+\R?//gm;t' <<< "one1:text1
one1:text2
one3:text1
one2:text3
one2:text1
one4:text1"