const regex = /(?-s)^([^:]+:).*(\R\1.*)+\R?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?-s)^([^:]+:).*(\\R\\1.*)+\\R?', 'gm')
const str = `one1:text1
one1:text2
one3:text1
one2:text3
one2:text1
one4:text1`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);