#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?-s)^([^:]+:).*(\R\1.*)+\R?"
Local $sString = "one1:text1" & @CRLF & _
"one1:text2" & @CRLF & _
"one3:text1" & @CRLF & _
"one2:text3" & @CRLF & _
"one2:text1" & @CRLF & _
"one4:text1"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)