$re = '/(?-s)^([^:]+:).*(\R\1.*)+\R?/m';
$str = 'one1:text1
one1:text2
one3:text1
one2:text3
one2:text1
one4:text1';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;