import Foundation
let pattern = #"(?-s)^([^:]+:).*(\R\1.*)+\R?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
one1:text1
one1:text2
one3:text1
one2:text3
one2:text1
one4:text1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)