use strict;
my $str = 'one1:text1
one1:text2
one3:text1
one2:text3
one2:text1
one4:text1';
my $regex = qr/(?-s)^([^:]+:).*(\R\1.*)+\R?/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";