# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\S+?)\s*=\s*\"([^\t]+)\"\s*(?>;\s*\n)/^[#;].*/gU;t' <<< "key_1= \"vdsdsalh\";
multiline_key = \"something
with
many lines\";
Key2 = \"test with ; symbol\";
"