re = /(\S+?)\s*=\s*\"([^\t]+)\"\s*(?>;\s*\n)/
str = 'key_1= "vdsdsalh";
multiline_key = "something
with
many lines";
Key2 = "test with ; symbol";
'
subst = '^[#;].*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result