$re = '/(\S+?)\s*=\s*\"([^\t]+)\"\s*(?>;\s*\n)/U';
$str = 'key_1= "vdsdsalh";
multiline_key = "something
with
many lines";
Key2 = "test with ; symbol";
';
$subst = "^[#;].*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;