using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S+?)\s*=\s*\""([^\t]+)\""\s*(?>;\s*\n)";
string substitution = @"^[#;].*";
string input = @"key_1= ""vdsdsalh"";
multiline_key = ""something
with
many lines"";
Key2 = ""test with ; symbol"";
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}